php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33297 double backlash and single backlash is same in eregi
Submitted: 2005-06-10 13:23 UTC Modified: 2005-06-11 15:13 UTC
From: hv at trust-mart dot com Assigned:
Status: Not a bug Package: Regexps related
PHP Version: 4.3.11 OS: linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: hv at trust-mart dot com
New email:
PHP Version: OS:

 

 [2005-06-10 13:23 UTC] hv at trust-mart dot com
Description:
------------
The double backlash and single backlash is same result in eregi.

Reproduce code:
---------------
These codes are judging "$domain" in right or wrong format.
But two lines get the same result.Could any one tell me why?
Thanks!

eregi("^[0-9a-z]([-.]?[0-9a-z])*\\.[a-z]{2,4}$", $domain
eregi("^[0-9a-z]([-.]?[0-9a-z])*\.[a-z]{2,4}$", $domain


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-06-11 15:13 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jul 05 09:05:45 2022 UTC