php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33265 Can't prase PHP on html page anymore
Submitted: 2005-06-07 18:04 UTC Modified: 2005-06-07 18:26 UTC
From: vishal at trpn dot com Assigned:
Status: Not a bug Package: *Web Server problem
PHP Version: 4.3.11 OS: Fedora 2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: vishal at trpn dot com
New email:
PHP Version: OS:

 

 [2005-06-07 18:04 UTC] vishal at trpn dot com
Description:
------------
I had it working on previous websites, however for some reason it is not working anymore :( 

I have tried both lines in .htaccess file but with no success. 

AddHandler application/x-httpd-php .html 
AddType application/x-httpd-php .html 

Any help. I really need to use php on .html page.

P.S. I am using PHP Version 4.3.11. 



Reproduce code:
---------------
<!doctype html public "-//W3C//DTD HTML 4.0 //EN">
<html>
<head>
       <title>Test Page for PHP on .html page</title>
</head>
<body>

The time is
<?php echo date('H:i:s');?>
and the date is
<?php echo date('j F Y');?>


</body>
</html>

Expected result:
----------------
Expected php codes to work properly only .html pages.

Actual result:
--------------
500 Internal Server Error


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-06-07 18:21 UTC] johannes@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

. 
 [2005-06-07 18:26 UTC] vishal at trpn dot com
I am sorry, but how is this not a bug? I mean it use to work just fine before but it does not work in newer version of php.

Just wondering.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jun 19 16:01:23 2021 UTC