php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #332 php.cgi -e merge.php3p dumps core
Submitted: 1998-04-29 23:29 UTC Modified: 2000-07-05 02:32 UTC
From: lynch at lscorp dot com Assigned:
Status: Closed Package: Reproducible Crash
PHP Version: 3.0b6 OS: Linux ruby.inet-images.com 2.0.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: lynch at lscorp dot com
New email:
PHP Version: OS:

 

 [1998-04-29 23:29 UTC] lynch at lscorp dot com
I tried the pretokenizer on a lark with a huge (1200+ line) script:

[chatmus@ruby www]$ /iiw/cgi-bin/chatmusic.com/php.cgi -e merge.php3p
Content-type: text/html

<HTML>
  <HEAD><TITLE>Merge Paul's data with Old data</TITLE></HEAD>
  <BODY>
    285 records to process.  Each dot represents one record.<BR>
.<BR>
<br>
<b>Fatal error</b>:  Call to unsupported or undefined function expg_freeresu() in <b>merge.php3p</b> on line <b>379</b><br>
Segmentation fault (core dumped)

The script, .php3p, .ini and core files are all available at:

http://chatmusic.com/bug/

They were originally up one level, but I copied them to /bug so I could mess with my merge script some more.

The only thing I might be doing that is at all rare would be to reuse a variable in a loop and free it each time... and that can't be that uncommon.  I only say this since that is what it would be doing soon after emitting the .<BR> above.

You can check 
http://chatmusic.com/cgi-bin/php.cgi/phpinfo.htm
for the compile info.  I'd probably misreport it through ignorance anyway.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-05 02:32 UTC] rasmus at cvs dot php dot net
Long dead bug
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Nov 22 23:01:25 2019 UTC