php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3319 php3_auto_prepend directive in .htaccess is remembered
Submitted: 2000-01-26 11:46 UTC Modified: 2002-10-01 14:30 UTC
From: chris at jeks dot net Assigned:
Status: Wont fix Package: Misbehaving function
PHP Version: 3.0.14 OS: Redhat Linux 6.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
47 - 43 = ?
Subscribe to this entry?

 
 [2000-01-26 11:46 UTC] chris at jeks dot net
Hi,

I have this problem:

I have multiple PHP script installs that use PHPLib functionality. They all have .htaccess files that set php3_auto_prepend_file. I do not have the auto_prepend_file
var set in php3.ini.

In PHP < 3.0.14 I had no trouble. 

Now going into one directory with a .htaccess file specifying a php3_auto_prepend_file, then moving to one without - the setting from previously remains causing errors.

E.g.

www.server.com/directory1
 .htaccess:
    php3_auto_prepend_file /some/file
    php3_include_path      /some/directories           

www.server.com/directory2
 .htaccess
    php3_include_path     /some/other/directory

Load /directory1, then load directory2 and the setting for
php3_auto_prepend_file remains. This didn't used to happen.

Bug or intended behaviour?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-01 14:30 UTC] hholzgra@php.net
We are sorry, but can not support PHP 3 related problems anymore.
Momentum is gathering for PHP 5, and we think supporting PHP 3 will
lead to a waste of resources which we want to put into getting PHP 5
ready. Ofcourse PHP 4 will will continue to be supported for the
forseeable future.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Aug 12 06:01:25 2020 UTC