php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33143 max_file_size hangs post
Submitted: 2005-05-25 22:12 UTC Modified: 2005-05-30 01:02 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: webnerd at comcast dot net Assigned:
Status: Not a bug Package: HTTP related
PHP Version: 4.3.11 OS: RedHat Linux 2.6.9 Apache 2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: webnerd at comcast dot net
New email:
PHP Version: OS:

 

 [2005-05-25 22:12 UTC] webnerd at comcast dot net
Description:
------------
Server still tries to upload files larger than MAX_FILE_SIZE when submitted through form.  display_errors is turned off but the error log shows within seconds of attempt:

PHP Warning:  MAX_FILE_SIZE of 1000 bytes exceeded

but browser window does not stop trying to load the file.  This is been tested in IE and Firefox with the same results.


Reproduce code:
---------------
To reproduce, please check the following URL:

http://www.kyouradio.com/tmpup/progressbartest.php

Expected result:
----------------
Upon submitting a file, a window will popup that will immediately resize to show a status-bar effect.  The new window then issues a Javascript command to change the MAX_FILE_SIZE value to 60MB and then forces the main form to submit. The "popup" window performs as an upload progress bar.

Actual result:
--------------
Once clicking submit, the new window opens but "hangs" while the server tries to parse the file input, however, the following shows up in the error log:

PHP Warning:  MAX_FILE_SIZE of 1000 bytes exceeded

The new window eventually resizes but the timing between the POST and the resize tells me that the server has not stopped trying to process the upload to the popup window. Which in turn, results in 2 upload attempts of really large files.




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-05-26 04:46 UTC] webnerd at comcast dot net
Am I incorrect to assume that a PHP Warning will cause the POSTED file to discontinue being posted?  The PHP documentation states:

"This is an advisory to the browser, PHP also checks it"

But PHP does nothing with the larger upload attempt besides log a warning in the error log and continue the upload??
 [2005-05-26 21:29 UTC] webnerd at comcast dot net
I have read another user's comments on this issue and still don't see the purpose of the MAX_FILE_SIZE since the browser does not read it and PHP doesn't read it until after Apache has received the Post data.
 [2005-05-30 01:02 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Oct 28 06:03:33 2021 UTC