php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33133 Translations Not Working Correctly
Submitted: 2005-05-25 04:14 UTC Modified: 2005-05-25 11:23 UTC
From: larryjadams at comcast dot net Assigned:
Status: Not a bug Package: Gettext related
PHP Version: 5.0.4 OS: WindowsXP Pro
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: larryjadams at comcast dot net
New email:
PHP Version: OS:

 

 [2005-05-25 04:14 UTC] larryjadams at comcast dot net
Description:
------------
When I use the builtin Gettext dll file in PHP 5.0.4, my translations do not work correctly.  Translation strings are being interpreted and output.  However, special characters end up being in another unknown language.

When I use the Savannah Groups php-gettext, everything is A Ok in English, French and Japanese.

I also can not use LC_MESSAGES as it is not a defined constant anymore when using setlocale.  I have to instead use LC_ALL which does not set properly.  The only way I can get the translated messages to appear is by settings the environment variable LC_ALL to the correct value.

Reproduce code:
---------------
I can send along the *.mo files and Jpeg files to demonstrate the output.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-05-25 11:23 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

..and I didn't understand a word of your report..

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Apr 10 13:01:24 2020 UTC