php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33111 make error: Value of enumeration constant must be in range of signed integer.
Submitted: 2005-05-23 13:24 UTC Modified: 2005-07-08 21:29 UTC
From: gregrlb at softhome dot net Assigned: wez (profile)
Status: Closed Package: PDO related
PHP Version: 5CVS-2005-05-23 OS: AIX 5.2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: gregrlb at softhome dot net
New email:
PHP Version: OS:

 

 [2005-05-23 13:24 UTC] gregrlb at softhome dot net
Description:
------------
Hi,

I can't do a 'make' of the last package I downloaded at "http://snaps.php.net/php5-200505231030.tar.gz" (latest cvs).

Anyone knows how I can solve it?

Thanks,

Greg.

Reproduce code:
---------------
cd /php5-200505231030
./configure
make

Actual result:
--------------
        cc  -Iext/pdo/ -I/tmp2/php5-200505231030/ext/pdo/ -DPHP_ATOM_INC -I/tmp2/php5-200505231030/include -I/tmp2/php5-200505231030/main -I/tmp2/php5-200505231030 -I/opt/freeware/include/libxml2 -I/tmp2/php5-200505231030/TSRM -I/tmp2/php5-200505231030/Zend    -g  -c /tmp2/php5-200505231030/ext/pdo/pdo.c -o ext/pdo/pdo.o  && echo > ext/pdo/pdo.lo
"/tmp2/php5-200505231030/ext/pdo/php_pdo_driver.h", line 73.34: 1506-243 (S) Value of enumeration constant must be in range of signed integer.
make: 1254-004 The error code from the last command is 1.


Stop.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-05-23 15:51 UTC] wez@php.net
gregrlb: assuming that the error is referring to line 73 of php_pdo_driver.h (never seen a floating point line number before ;-), that line looks like this:

PDO_PARAM_INPUT_OUTPUT = 0x80000000

Could you try changing it to:

PDO_PARAM_INPUT_OUTPUT = 0x80000000L

and see if that makes the compiler happy?

 [2005-05-23 17:39 UTC] gregrlb at softhome dot net
cc  -Iext/pdo/ -I/tmp2/php5-200505231030/ext/pdo/ -DPHP_ATOM_INC -I/tmp2/php5-200505231030/include -I/tmp2/php5-200505231030/main -I/tmp2/php5-200505231030 -I/opt/freeware/include/libxml2 -I/tmp2/php5-200505231030/TSRM -I/tmp2/php5-200505231030/Zend    -g  -c /tmp2/php5-200505231030/ext/pdo/pdo.c -o ext/pdo/pdo.o  && echo > ext/pdo/pdo.lo
"/tmp2/php5-200505231030/ext/pdo/php_pdo_driver.h", line 73.34: 1506-243 (S) Value of enumeration constant must be in range of signed integer.
make: 1254-004 The error code from the last command is 1.


Stop.
 [2005-07-08 21:29 UTC] wez@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Oct 24 07:03:34 2021 UTC