php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33094 Too deep recursion leads to segfault
Submitted: 2005-05-21 18:42 UTC Modified: 2005-05-21 19:17 UTC
From: manager at mirchevideas dot com Assigned:
Status: Wont fix Package: Reproducible crash
PHP Version: 4.3.10 OS: Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: manager at mirchevideas dot com
New email:
PHP Version: OS:

 

 [2005-05-21 18:42 UTC] manager at mirchevideas dot com
Description:
------------
Segfault of the httpd server

Reproduce code:
---------------
<?php
	test(1);
	echo 'you should never see this';
	
	function test($level) {
		echo $level . '<br>'; flush();
		test($level+1);
	}
?>

Expected result:
----------------
Fatal error : Nesting level too deep - recursive dependency?

Actual result:
--------------
Going up to ~21000 and then just stopping to print. This is because it segfaulted.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-05-21 19:17 UTC] tony2001@php.net
Search the bug database before submitting new reports.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Mar 04 13:01:25 2021 UTC