php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33089 Ibase dont work with special caracteres (^ ~ ?)
Submitted: 2005-05-21 10:26 UTC Modified: 2005-05-23 10:31 UTC
From: koyote at task dot com dot br Assigned:
Status: Not a bug Package: InterBase related
PHP Version: 5.0.4 OS: Windows Xp
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: koyote at task dot com dot br
New email:
PHP Version: OS:

 

 [2005-05-21 10:26 UTC] koyote at task dot com dot br
Description:
------------
I have a table of cities and some of then have accent, like Arax? .
If i make a normal sql SELECT * FROM CITIES
where have ID, NAME and STATE. The function starts to collect from the database and print in the screen. But when it reads a city that have accent it stops and generates a Warning.
I had search a lot in the internet and i couldnt find anything about it. I think that ibase have problems to read accent in Interbase Databases.


Reproduce code:
---------------
 <?php $result[$i] = ibase_fetch_row($this->sth); ?>

Expected result:
----------------
It should return a string with all the values from each field of the row.

Actual result:
--------------
PHP Warning: ibase_fetch_row() [function.ibase-fetch-row]: arithmetic exception, numeric overflow, or string truncation Cannot transliterate character between character sets in C:\Inetpub\wwwroot\croquiteca\banco.php on line 45 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-05-23 10:31 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

RTFM: http://www.php.net/ibase_connect 
(the 4th 'Note:' paragraph)

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Nov 29 11:01:23 2020 UTC