php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #33045 reflection api is not documented
Submitted: 2005-05-17 08:54 UTC Modified: 2021-05-23 04:30 UTC
Votes:3
Avg. Score:4.3 ± 0.9
Reproduced:2 of 3 (66.7%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: cweiske at cweiske dot de Assigned:
Status: Wont fix Package: Reflection related
PHP Version: Irrelevant OS: any
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: cweiske at cweiske dot de
New email:
PHP Version: OS:

 

 [2005-05-17 08:54 UTC] cweiske at cweiske dot de
Description:
------------
The reflection api is not documented in a way that makes it easy for extension developers to support parameter reflection in their extensions.

I wrote a small howto which covers this:
http://www.cweiske.de/howto/hackingphp5/Hacking.html

Just contact me if you want the docbook sources.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-05-17 16:07 UTC] nlopess@php.net
In fact, we don't have any documentation that can help extension developers..
Although it would be good to have a developers' manual, it doesn't exist. And we will not document this in the main manual.
 [2005-05-17 19:35 UTC] wez@php.net
We *do* have other extension developer docs.
Someone might document the reflection API related features someday.
 [2009-03-30 10:51 UTC] cweiske@php.net
Docbook sources: http://tmp.cweiske.de/HackingPHP5.xml
 [2016-06-29 17:28 UTC] cmb@php.net
-Status: Suspended +Status: Feedback -Assigned To: +Assigned To: cmb
 [2016-06-29 17:28 UTC] cmb@php.net
> Docbook sources: http://tmp.cweiske.de/HackingPHP5.xml

404 Not found.
 [2016-06-29 18:15 UTC] cweiske@php.net
I've restored the file.
 [2016-06-29 18:33 UTC] cmb@php.net
> I've restored the file.

Thanks. Having had a quick glance at the file, it seems to be a
good addition to "PHP at the Core: A Hacker's Guide"[1]. To do so
would require to transfer the copyright to the "PHP Documentation
Group" and to change the license to CC BY 3.0[2]. Would you agree
to do so?

[1] <http://php.net/manual/en/internals2.php>
[2] <http://php.net/manual/en/copyright.php>
 [2016-06-29 18:41 UTC] cweiske@php.net
Yes, I agree to the license change and copyright transfer.
 [2016-06-29 19:02 UTC] cmb@php.net
-Status: Feedback +Status: Verified -Package: Documentation problem +Package: Reflection related
 [2016-06-29 19:02 UTC] cmb@php.net
> Yes, I agree to the license change and copyright transfer.

Thanks. Will include the doc ASAP.
 [2017-10-24 05:26 UTC] kalle@php.net
-Status: Verified +Status: Assigned
 [2019-06-28 11:36 UTC] cmb@php.net
-Status: Assigned +Status: Open -Assigned To: cmb +Assigned To:
 [2019-06-28 11:36 UTC] cmb@php.net
Well, since quite a while I don't think it makes sense to add
internals documentation to the PHP manual, because there is
insufficient man power to maintain what's already there.  In my
opinion, out-dated documentation is worse than no documentation.

Unassigning myself, so that perhaps somebody else will take this
to <http://www.phpinternalsbook.com/> or somewhere else, where it
can be maintained.

Thanks!
 [2021-05-23 04:30 UTC] krakjoe@php.net
-Status: Open +Status: Wont fix
 [2021-05-23 04:30 UTC] krakjoe@php.net
We can wrap this one up ...

It's not just Christoph that thinks internals documentation doesn't belong in the manual, this is certainly the modern consensus among internals developers.

There is an external attempt to maintain some useful documentation which Christoph mentioned, and even that is lagging behind and is incomplete.

I'm going to close this as Won't Fix, as it seems outside of the scope of normal documentation.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 23 20:03:38 2021 UTC