php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32975 Include ignores query string
Submitted: 2005-05-08 03:30 UTC Modified: 2005-05-08 04:35 UTC
From: gilthans at gmail dot com Assigned:
Status: Not a bug Package: Directory function related
PHP Version: 4.3.11 OS: Windows XP IIS
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gilthans at gmail dot com
New email:
PHP Version: OS:

 

 [2005-05-08 03:30 UTC] gilthans at gmail dot com
Description:
------------
The 'include' function ignores the query string, and seems to think it is part of the filename, thus, when I attempt to include a file with a query string included, it says the file does not exist. When the query string is removed, it works.

Reproduce code:
---------------
include('somepage.php'); //Works fine
include('somepage.php?banner=1'); //Doesn't work

Expected result:
----------------
Inclusion of the file, with the url recieving the query string normally.

Actual result:
--------------
It will output a "cannot find file or directory" warning.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-05-08 04:35 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Dec 04 17:01:23 2020 UTC