php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32969 ereg_replace can't handle certain char
Submitted: 2005-05-06 18:46 UTC Modified: 2005-05-06 22:59 UTC
From: oortm at gmx dot net Assigned:
Status: Not a bug Package: Regexps related
PHP Version: 4.3.9 OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
27 + 8 = ?
Subscribe to this entry?

 
 [2005-05-06 18:46 UTC] oortm at gmx dot net
Description:
------------
The ereg_replace-function can't handle a closing hook in a string as parameter. Try this to reproduce the bug:

$message = ereg_replace(":-)","<img src='../images/hi.gif'>",$message);

It chokes on the first parameter seeing a ')'. As the string is enclosed by quotes it shouldn't do this and parse on the string until the last quote is found.

oortm
netherlands


Reproduce code:
---------------
$message = ereg_replace(":-)","<img src='../images/hi.gif'>",$message);



Expected result:
----------------
1. modified content of the string entitled 'message'
2. unmodifed content of the string entitled 'message'



Actual result:
--------------
script is exited


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-05-06 22:59 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jul 05 10:05:45 2022 UTC