|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3290 seg.fault with Oracle InterOffice with IMAP4r1 (
Submitted: 2000-01-24 03:46 UTC Modified: 2001-02-10 15:26 UTC
From: sysadmin at siag dot it Assigned:
Status: Closed Package: IMAP related
PHP Version: 3.0.14 OS: RedHat-6.0
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: sysadmin at siag dot it
New email:
PHP Version: OS:


 [2000-01-24 03:46 UTC] sysadmin at siag dot it

I've tried to use IMP as a WEB-Frontend for Oracle InterOffice with IMAP4r1 (,
but there seems to exist an authentication problem, which doesn't appear when connecting
natively with Netscape IMAP-Mailclient.

On the serverside I get the following apache errorlog:

[Sat Jan 15 20:10:55 2000] [notice] child pid 19009 exit signal Segmentation fault (11)
[Sat Jan 15 20:10:57 2000] [notice] child pid 19000 exit signal Segmentation fault (11)
[Sat Jan 15 20:14:17 2000] [notice] child pid 18999 exit signal Segmentation fault (11)
[Sat Jan 15 20:33:59 2000] [error] Possible PHP3 memory leak detected (harmless):  5 bytes from functions/mime.c:240
[Sat Jan 15 20:33:59 2000] [error] Possible PHP3 memory leak detected (harmless):  1 bytes from functions/mime.c:148
[Sat Jan 15 20:33:59 2000] [error] Possible PHP3 memory leak detected (harmless):  2 bytes from functions/mime.c:266

on the clientside (Netscape) I get "document contains no data ..."

Having tried to circumvent the problem by using an IMAP-proxy server (prediction)
) the problem remains the same.

Therefore I think the bug is burried somewhere in an commonly used imap library.
Could you tell me please which libraries IMP/php3/apache uses for IMAP 

Do you have any ideas on how to remove  the problem?


(these two packages I tried also in the latest stable release versions 
with the same result)



Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2000-08-19 21:17 UTC]
Are you still having this problem?
Could you read
and see if you can get a backtrace if so?
 [2001-02-10 15:26 UTC]
no feedback, closing.
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Jan 23 20:03:35 2022 UTC