php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32752 Unable to load dynamic library and signal Segmentation fault
Submitted: 2005-04-18 22:34 UTC Modified: 2005-04-19 08:49 UTC
From: dcvoyager at gmail dot com Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 5.0.4 OS: Red Hat enterprise Linuxe ES 3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dcvoyager at gmail dot com
New email:
PHP Version: OS:

 

 [2005-04-18 22:34 UTC] dcvoyager at gmail dot com
Description:
------------
I have redhat enterprise (ES) version 3 and I had php-4.3.2-19.ent instaled on it with httpd-2.0.46-44.ent and mysql-4.1.11.

I upgraded my php to 5.0.4 and my configure was 
./configure --prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \
--sbindir=/usr/sbin \
--sysconfdir=/etc \
--datadir=/usr/share \
--includedir=/usr/include \
--libdir=/usr/lib \
--libexecdir=/usr/libexec \
--localstatedir=/var \
--sharedstatedir=/usr/com \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--cache-file=../config.cache \
--with-config-file-path=/etc \
--with-config-file-scan-dir=/etc/php.d \
--enable-force-cgi-redirect \
--disable-debug \
--enable-pic \
--disable-rpath \
--enable-inline-optimization \
--with-bz2 \
--with-db4=/usr \
--with-curl \
--with-dom=/usr \
--with-exec-dir=/usr/bin \
--with-freetype-dir=/usr \
--with-png-dir=/usr \
--with-gd \
--enable-gd-native-ttf \
--with-ttf \
--with-gettext \
--with-ncurses \
--with-gmp \
--with-iconv \
--with-jpeg-dir=/usr \
--with-openssl \
--with-png \
--with-pspell \
--with-regex=system \
--with-xml \
--with-expat-dir=/usr \
--with-pcre-regex=/usr \
--with-zlib \
--with-layout=GNU \
--enable-bcmath \
--enable-exif \
--enable-ftp \
--enable-magic-quotes \
--enable-safe-mode \
--enable-sockets \
--enable-sysvsem \
--enable-sysvshm \
--enable-discard-path \
--enable-track-vars \
--enable-trans-sid \
--enable-yp \
--enable-wddx \
--enable-mbstring \
--enable-mbstr-enc-trans \
--enable-mbregex \
--without-oci8 \
--with-pear=/usr/share/pear \
--with-imap=shared --with-imap-ssl \
--with-kerberos=/usr/kerberos \
--with-ldap=shared \
--with-mysql=shared,/usr \
--with-pgsql=shared \
--with-unixODBC=shared \
--enable-memory-limit \
--enable-bcmath \
--enable-shmop \
--enable-versioning \
--enable-calendar \
--enable-dbx \
--enable-dio \
--enable-mcal \
--with-apxs2filter=/usr/sbin/apxs

after the make and make install, I restarted apache, now none of my php scripst works. When I looked at the error logs for httpd it gives this error
[******error*****]
[Mon Apr 18 15:08:08 2005] [notice] child pid 25188 exit signal Segmentation fault (11) 

and also these errors

PHP Warning:  PHP Startup: : Unable to initialize module
Module compiled with module API=20020429, debug=0, thread-safety=0
PHP    compiled with module API=20041030, debug=0, thread-safety=0
These options need to match
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php4/ldap.so' - /usr/lib/php4/ldap.so: undefined symbol: OnUpdateInt in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php4/mysql.so' - /usr/lib/php4/mysql.so: undefined symbol: OnUpdateInt in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php4/odbc.so' - /usr/lib/php4/odbc.so: undefined symbol: OnUpdateInt in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php4/pgsql.so' - /usr/lib/php4/pgsql.so: undefined symbol: OnUpdateInt in Unknown on line 0
 

Actual result:
--------------
How can I make php to run normal?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-04-19 00:13 UTC] dcvoyager at gmail dot com
Now I get these errors in httpd error log after changing the extension dir in php.ini apart and also this 

[Mon Apr 18 15:08:08 2005] [notice] child pid 25188 exit signal Segmentation fault (11)

PHP Warning:  PHP Startup: : Unable to initialize module!Module compiled with module API=20020429, debug=0, 

thread-safety=0!PHP    compiled with module API=20041030, debug=0, thread-safety=0!These options need to match! in Unknown on line 0
PHP Warning:  PHP Startup: !!!!!M!!: Unable to initialize module!Module compiled with module API=20020429, debug=0, 
thread-safety=0!PHP    compiled with module API=20041030, debug=0, thread-safety=0!These options need to match! in Unknown on 

line 0
PHP Warning:  PHP Startup: !!!! V!!: Unable to initialize module!Module compiled with module API=20020429, debug=0, 

thread-safety=0!PHP    compiled with module API=20041030, debug=0, thread-safety=0!These options need to match! in Unknown on 

line 0
PHP Warning:  PHP Startup: !!!!!]!!: Unable to initialize module!Module compiled with module API=20020429, debug=0, 

thread-safety=0!PHP    compiled with module API=20041030, debug=0, thread-safety=0!These options need to match! in Unknown on 

line 0
PHP Warning:  PHP Startup: !!!!!!!!: Unable to initialize module!Module compiled with module API=20020429, debug=0, 

thread-safety=0!PHP    compiled with module API=20041030, debug=0, thread-safety=0!These options need to match! in Unknown on 

line 0
 [2005-04-19 08:49 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Feb 23 16:01:28 2024 UTC