php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32737 Encoding Problem in mysqli functions
Submitted: 2005-04-17 13:38 UTC Modified: 2005-04-17 14:37 UTC
From: vahedi at gmail dot com Assigned:
Status: Not a bug Package: MySQLi related
PHP Version: 5.0.3 OS: windows(xp,2000) - linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: vahedi at gmail dot com
New email:
PHP Version: OS:

 

 [2005-04-17 13:38 UTC] vahedi at gmail dot com
Description:
------------
hi,
my setting (winxp+sp2 , apache2 , mysql 4.1.10 , php 5.0.3).

i have a mysql database with 3 tables that contain information with UNICODE(UTF-8) encoding.
i didnot have any problem with my application when i used from mysql functions in php.
but after php version 5, when i used from mysqli functions, i see undefined charactes on my web page.

of course, when i add a new record to my database with mysqli and see that record with it, i havenot any problem.

do i must enter all of old data into my db with mysqli functions?

please help me, that how i see correctly my old data with new functions?

thank you



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-04-17 14:37 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun May 16 10:01:24 2021 UTC