php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #32733 libmysqli.dll not included w/5.0.4 & PHP_MySQL.DLL & PHP_MySQL.DLL won't load
Submitted: 2005-04-17 06:50 UTC Modified: 2005-04-17 21:35 UTC
From: jason at thinkingman dot org Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 5.0.4 OS: XP (SP2)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jason at thinkingman dot org
New email:
PHP Version: OS:

 

 [2005-04-17 06:50 UTC] jason at thinkingman dot org
Description:
------------
Just upgraded to 5.0.4 (from 5.0.2) -- MySqli & MySql DLL's (Extensions won't load when IIS starts.  Get error message saying Unable to Load.

PHP.INI is conf'd correctly -- paths are good, OS paths are good -- no dup DLL's on system.  Reinstalled 5.0.2 everything works fine again.

It looks like libmysqli.dll was included in the .ZIP distro -- looks like this was a problem with the 5.0.3 distro as well.




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-04-17 06:51 UTC] jason at thinkingman dot org
Typo --

It looks like libmysqli.dll was NOT included in the .ZIP distro -- looks like this was a problem with the 5.0.3 distro as well.
 [2005-04-17 14:46 UTC] sniper@php.net
There's something wrong with either your installation method or the mirror you're downloading the package from. There definately IS php_mysqli.dll in the zip package..

 [2005-04-17 14:53 UTC] sniper@php.net
Reopening and relclassifyin as documentation probelm since the release package (and snapshots) seem to have all the dlls now in the 'root' of the package. The install.txt needs a bit of tuning..

Jason, FYI: The libmysql.dll is NOT the extension. The extensions are found in ext/ directory. 
 [2005-04-17 19:33 UTC] jason at thinkingman dot org
Problem isn't *my* installation method chief.  Been using Zip/Winzip for the better half of 20 years - but thanks for making someone else's fuckup an issue w/ me -- truly appreciate 'A' types like u who think the problem is always the person having the problem.  

The ZIP I download (from whatever mirror) DID NOT have libmysqli.dll (notice the "i".)  You clearly didn't not read my posting correctly.

And, never said PHP_MySQL.DLL or PHP_MySQLi.DLL weren't there -- what *I* said was, LibMySQLi.DLL is *missing* from the distro.  I don't know how you jumped to the assumption that somehow I think LibMySQL.DLL is an extension, nor the assumption that I don't know where the extensions are stored.

The problem (Chief) is on your end; Mirrors or Not -- not my end. Fix it, repost it (to all mirrors.)

Cool?
 [2005-04-17 19:38 UTC] derick@php.net
There is no libmysqlI.dll - it doesn't exist. And I suggest you tone down a bit - we're all volunteers here.
 [2005-04-17 20:27 UTC] jason at thinkingman dot org
I understand you are volunteers, and *believe* me when I say I think you are all *awesome* -- but please be responsible, respective, and kind to others with your words also.  Clearly 'sniper' *reacted* to my posting, instead of reading it and *responding* appropriately to it -- unf. this seems all to common -- not just here.

As for the LibMySQLi.DLL -- this was part of 5.0.2 -- has it been removed?  I placed LibMySQLi.DLL from my 5.0.2 distro in 5.0.4 but this didn't seem to fix the problem -- when PHP would load through the starting of IIS I would get the message "Unable to Load PHP_MySQLi.DLL, extension not found" {message isn't exactly that, but similar.  Same for PHP_MySQL.DLL -- even though LibMySQL.DLL is in PHP Root.

Again, all my paths are correct, all my OS NTFS Permissions are correct / open, and PHP.INI is correct.  But I still get this error.  When I simply replaced 5.0.4 with 5.0.2 -- it all works again.  I have no duplicate dlls. And I see the LibMySQLi.DLL in my 5.0.2 distro -- so I'm left with the 5.0.4 distro being broken.  

Jason
 [2005-04-17 20:38 UTC] nlopess@php.net
The libmysqli.dll lib was replaced by libmysql.dll.
This is documented at http://php.net/manual/en/install.windows.extensions.php
 [2005-04-17 20:51 UTC] jason at thinkingman dot org
I have read that, although it doesn't explicitly say -- it does imply in 5.0.3 and above it's just LibMySQL.DLL. However, I'm still left with the problem of the PHP_MYSQLi.DLL and PHP_MYSQL.DLL extensions not loading.

My Extensions are located in C:\DEV\PHP5\ext

This path is correctly defined in my PHP.INI and my OS's environment.

Yet each time I restart IIS I get that error; Unable to Load Extension PHP_MySQLi.DLL (same for PHP_MySQL.DLL) -- cannot be located.  And they do exist in my .;\ext folder
 [2005-04-17 20:57 UTC] nlopess@php.net
its your misconfiguration problem.
Or you don't have C:\dev\php5 in the path or something else.

But here it isn't the place to ask for that kind of suppport. The archive is good, php 5.0.4 works, and the change is documented.
 [2005-04-17 20:58 UTC] jason at thinkingman dot org
For giggles; I've redownloaded 5.0.4 ZIP'd distro and reinstalled.  I get the error.  Here's what it says exactly:

WARNING:
PHP Startup; Unable to load dynamic library '\dev\php5\ext\php_mysql.dll' - The specified procedure could not be found.

Then I get another pop-up warning; same message except for PHP_MySQLi.DLL.
 [2005-04-17 21:00 UTC] jason at thinkingman dot org
IT ISN'T MY MISCONIFG PROB.  I HAVE STATED THAT ALL MY PATHS ARE CORRECT IN THE PHP.INI AND OS ENVIRONMENT -- NOTHING HAS CHANGED.

COME'ON PEOPLE.
 [2005-04-17 21:09 UTC] jason at thinkingman dot org
I just performed a command line WHICH statement on the following:

PHP.EXE
PHP_MYSQL.DLL
PHP_MYSQLi.DLL

It find'em in 
C:\DEV\PHP5 --> php.exe
C:\DEV\PHP5\ext --> PHP_MySQL.DLL
C:\DEV\PHP5\ext --> PHP_MySQLi.DLL

My PHP.INI:
; Directory in which the loadable extensions (modules) reside.
extension_dir = "c:\dev\php5\ext"
 [2005-04-17 21:14 UTC] nlopess@php.net
yep, those paths are correct.
You probably don't have the php dir in the path.

And please don't reopen this bug report.
 [2005-04-17 21:16 UTC] jason at thinkingman dot org
The WHICH statement wouldn't work on (wouldn't find those) files if they wern't in my PATH.  Case has be re-opened.
 [2005-04-17 21:20 UTC] nlopess@php.net
Probably you are using the cygwin's which, which also searches in the cygwin own paths.
Anyway, probably you have some old libmysql.dll file somewhere in the windows dirs... Pleaske ask your questions elsewhere.

And I said don't reopen the bug report!
 [2005-04-17 21:21 UTC] betz@php.net
Please, Jason clam down. And do not shout.

5.0.4 on win32 does work for as intended, along with mysql support.
It is really your configuration problem, no?
Are you that special, that it does work for all others but not for you?
Given these facts, it is really not any problem related to php.

Fix your installation, ask for help on php-general and stop reopening this bug-report.

Kind Regards
Friedhelm


 [2005-04-17 21:35 UTC] jason at thinkingman dot org
nlopess & Friedhelm you're right.  Special thx to nlopess -- I didn't realize I had the older (5.0.2) LibMySQL.DLL and LibMySQLi.DLL in my System32 folder.  I deleted these, and restarted IIS and all works fine.

I'm not certain at what point I got brain cramps and decided to copy those DLLs into my system folder -- hence, my confusion.  Not something I would normally do.

I apologize to ALL for being an ASS.  Please forgive. ;)
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Jun 22 14:01:23 2021 UTC