php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32693 php crashes with the error: PHP has encountered an Access Violation at 77FCC35A
Submitted: 2005-04-13 13:00 UTC Modified: 2005-04-14 15:10 UTC
From: lmayer at cswg dot com Assigned:
Status: Not a bug Package: Performance problem
PHP Version: 4.3.10 OS: windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: lmayer at cswg dot com
New email:
PHP Version: OS:

 

 [2005-04-13 13:00 UTC] lmayer at cswg dot com
Description:
------------
when there is a lot of activity on the server e.g. file uploads especially, regular traffic doesn't seem to matter, PHP will crash. 

- nothing in server error log, nothing in SQL server error log
- nothing on any internet web search. I search every possible parameter.

- changed directoy in PHP.ini on upload_tmp_dir to D:\Inetpub\wwwroot\Corp\Trans\PHP with correct permissions
- changed permissions on session.save_path= C:\PHP\sessiondata  to give write permissions to both internet guest accounts.
- added mssql_close to the upload files: errorcheck, upload, step4 and step 3 to  with the connection information at the end of the script.

- fixes itself when you restart IIS and assorted services. 


Reproduce code:
---------------
There are 5 possible pages it could be. I haven't been able to narrow it down. 

Expected result:
----------------
I expect the PHP program not to crash when there is a lot of activity.

Actual result:
--------------
IIS continues to run other webpages continue to be displayed, however PHP stops running. Whenever you try to connect to a PHP page you get the message: PHP has encountered an Access Violation at 77FCC35A

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-04-13 19:52 UTC] lmayer at cswg dot com
Thanks for that. 

I did what you said although I went to 5.0.4 and now I've killed the server. PHP won't see the .ini file. The asp files on the same webserver run fine. Now instead of breaking once in a while it is completely hosed. I followed the directions exectly, right out of the install.txt. So almost 8 months of work is going to have to be completely redone in ASP. since I can't make this work at all.
 [2005-04-13 22:56 UTC] tony2001@php.net
That's definitely not a PHP problem, but your misconfiguration.
 [2005-04-14 15:10 UTC] lmayer at cswg dot com
Thanks for the help. I've stripped it of the often hacked old webserver and building a ew webserver as we speak. I am going to use the new build of the one you recommemded. I'm going to remove IIS and put Xitami on instead. I would guess it was a conflict between IIS5 and the version 4.3.10 that I was running. I never got a chance to test it with the new build. I noticed when I installed the one you said to use on my test machine it was CGI/FastCgi instead if ISAPI. Is that a better way to go?

Again thanks for taking the time to help.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jun 25 02:01:28 2024 UTC