php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32616 Call CURL'form upload from exec() 's problem !
Submitted: 2005-04-07 09:00 UTC Modified: 2005-04-08 02:57 UTC
From: fluzj at 21cn dot com Assigned:
Status: Not a bug Package: cURL related
PHP Version: 4.3.9 OS: RHEL4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: fluzj at 21cn dot com
New email:
PHP Version: OS:

 

 [2005-04-07 09:00 UTC] fluzj at 21cn dot com
Description:
------------
exec() call curl problem!
platform: RHEL4 (PHP 4.3.9  CURL 7.12.1 )

example:
/usr/bin/curl -k -s -S --connect-timeout 5 -F "option=$r_option" -F "upload=@/tmp/upload"  https://admin:admin@localhost:3444/upload.cgi

I want to upload the file througt form with the CURL.
it can work on the command console,but When i call it from exec(),it do nothing and return not 0 but 26. when i drop the @ sign,it can work with only upload content with "/tmp/upload".As the same the < sign is not work yet.I remember it can work in earlier version .I have not test on the 4.3.10 or 11 version. and use the system() function is the same problem.
thanks!




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-04-07 17:46 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2005-04-08 02:57 UTC] fluzj at 21cn dot com
I'm sorry to disturb you again,I have tested it on the PHP 4.2.3 from RHEL3. It can worked correctely,If it is not a PHP's bug just how to use it,Could you mind to tell me What shall i do?

Thank you very much!!
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Dec 08 10:01:24 2019 UTC