|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3253 Can not open any sockets
Submitted: 2000-01-19 13:09 UTC Modified: 2002-10-01 15:12 UTC
From: argus at sover dot net Assigned:
Status: Wont fix Package: Other
PHP Version: 3.0.14 OS: BSDI 4.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: argus at sover dot net
New email:
PHP Version: OS:


 [2000-01-19 13:09 UTC] argus at sover dot net
If I run any program that wants to use a socket (imap or fsockopen) they fail.

I tried this program:
$fp = fsockopen("", 80, &$errno, &$errstr, 30);
if(!$fp) {
	echo "$errstr ($errno)<br>\n";
} else {
	fputs($fp,"GET / HTTP/1.0\n\n");
	while(!feof($fp)) {
		echo fgets($fp,128);

and got the following output:

I have tried open a socket connection with fsock on an odd port, I have also tried opening an imap_open with the same results.  

I am not running php in safe mode, I am running it as an apache module and I do have it working on a BSDi 4.0.1 with php-3.0.12

-John Barrett


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2000-02-06 06:28 UTC] sas at cvs dot php dot net
Hint: Use truss to find out why it fails. 
 [2002-10-01 15:12 UTC]
We are sorry, but can not support PHP 3 related problems anymore.
Momentum is gathering for PHP 5, and we think supporting PHP 3 will
lead to a waste of resources which we want to put into getting PHP 5
ready. Ofcourse PHP 4 will will continue to be supported for the
forseeable future.

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Apr 24 10:01:31 2024 UTC