php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32399 isapi marshalling problem
Submitted: 2005-03-21 20:52 UTC Modified: 2005-04-01 01:00 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: shunt at ctg dot queensu dot ca Assigned:
Status: No Feedback Package: IIS related
PHP Version: 5.0.3 OS: windows 2003
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: shunt at ctg dot queensu dot ca
New email:
PHP Version: OS:

 

 [2005-03-21 20:52 UTC] shunt at ctg dot queensu dot ca
Description:
------------
Hi, 

This bug was already reported for a previous version of php.
(Bug #10480 ISAPI module conflicts with asp.dll) but I am having the same problem running a newer version of php and running IIS6. 
Thanks for your time on this. 

Steve.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-03-21 23:07 UTC] sniper@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 [2005-03-22 14:03 UTC] shunt at ctg dot queensu dot ca
Hi,

ok, I installed php 5.0.3 a few weeks ago and I also have some ASP pages that are in use as well. After installing php I noticed that if I go to one of my php pages and then over to an asp page the browser gives me this error:
'The application called an interface that was marshalled for a different thread.' After refreshing the browser a few times the asp page appears(anywhere from 1 - 5 refreshes does the trick), but then next time I visit the asp page it does it again until i restart the web services(running iis6) . All seems well with the asp pages UNTIL i run another php page and then the error appears again on the asp page. I use the php5isapi DLL as an isapi filter on my site(I also have php enabled as a web service extension using the same DLL). 
Hope this is enough info.

Steve.
 [2005-03-22 18:39 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip

Some threading issues are fixed recently, make sure you remove ALL old PHP related dlls before installing the snapshot! (and make sure you _really_ get them deleted before installing!)

 [2005-04-01 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Nov 30 22:05:53 2022 UTC