php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32319 PHP won't compile with libcurl 7.13.1
Submitted: 2005-03-15 17:41 UTC Modified: 2005-03-17 08:25 UTC
From: cece at syrup dot hu Assigned:
Status: Not a bug Package: cURL related
PHP Version: 4.3.10 OS: Debian Sarge
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
33 - 19 = ?
Subscribe to this entry?

 
 [2005-03-15 17:41 UTC] cece at syrup dot hu
Description:
------------
I tried to compile (configure) PHP with the actual libcurl (7.13.1) on Debian Sarge. Both 4.3.10 and 4.3.9 failed.

...
checking whether to enable calendar conversion support... no
checking for cpdflib support... no
checking for CRACKlib support... no
checking whether to enable ctype functions... yes
checking for CURL support... yes
checking for CURL in default path... found in /usr
checking for cURL 7.9.8 or greater... libcurl 7.13.1
checking for curl_easy_perform in -lcurl... no
configure: error: There is something wrong. Please check config.log for more information.

tail of my config.log:
...
configure:19409: checking for CRACKlib support
configure:19820: checking whether to enable ctype functions
configure:20083: checking for CURL support
configure:20132: checking for CURL in default path
configure:20150: checking for cURL 7.9.8 or greater
configure:20450: checking for curl_easy_perform in -lcurl
configure:20469: gcc -o conftest -g -O2   -lcurl -lidn -lssl -lcrypto -ldl -lssl -lcrypto -ldl -lz conftest.c -lcurl  -lcurl -lz -lresolv -lm -ldl -lnsl  -lcurl -lidn -lssl -lcrypto -ldl -lssl -lcrypto -ldl -lz 1>&5
/usr/lib/gcc-lib/i486-linux/3.3.5/../../../libcurl.so: undefined reference to `tld_strerror'
/usr/lib/gcc-lib/i486-linux/3.3.5/../../../libcurl.so: undefined reference to `idna_strerror'
collect2: ld returned 1 exit status
configure: failed program was:
#line 20458 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char curl_easy_perform();

int main() {
curl_easy_perform()
; return 0; }


my full configure line:
'./configure' '--with-apxs=/usr/local/apache/bin/apxs' '--enable-inline-optimization' '--with-zlib' '--with-gd' '--with-jpeg-dir=/usr' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-gif' '--with-t1lib' '--with-iconv' '--enable-ftp' '--enable-dbase' '--with-mysql' '--enable-trans-sid' '--enable-sockets' '--with-dom=/usr' '--with-curl' '--enable-bcmath'




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-03-16 00:57 UTC] sniper@php.net
And you are sure you've done clean install of the new curl version? ie. you don't have some old headers / curl-config files laying around? Try this:

# find / -name curl-config

You should get only one line..



 [2005-03-16 02:03 UTC] cece at syrup dot hu
Did not installed from source. Apt-getted libcurl3 and libcurl3-dev packages, the freshy ones. So, i think libcurl installed ok. 
Tested, only one curl-config present, under /usr/bin dir.
 [2005-03-16 02:10 UTC] cece at syrup dot hu
Additional information:

Tried to configure php on an another box (near virgin Debian Sarge) ) only with --with-curl option and got same results. Tested with 4.3.10 PHP version there.
 [2005-03-16 07:40 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

I think this is fixed in CVS, so please give it a go.

 [2005-03-16 12:11 UTC] cece at syrup dot hu
Negative. Tested with 200503160930 snapshot, same results.
 [2005-03-16 22:53 UTC] daniel-curl at haxx dot se
This is a known problem with libidn in Debian. Numerous bug reports have been filed, here's an example:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=299525
 [2005-03-17 08:25 UTC] derick@php.net
Not a bug in PHP, but in Debian's libidn package.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Nov 15 13:01:35 2019 UTC