php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32243 i am trying to search a dir
Submitted: 2005-03-09 05:57 UTC Modified: 2005-03-09 07:03 UTC
From: darkjedi3 at gmail dot com Assigned:
Status: Not a bug Package: Website problem
PHP Version: Irrelevant OS: windows xp
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: darkjedi3 at gmail dot com
New email:
PHP Version: OS:

 

 [2005-03-09 05:57 UTC] darkjedi3 at gmail dot com
Description:
------------
im am trying to search a dir, then spit out the files or whatever. i might not be able to search the dir though.

Reproduce code:
---------------
<?
//this script searchs C
print("<html>Files in C:\<br><br>");
$filesInC = scandir("C:\");
$numOfFilesInC = count($filesInC);
$i = 0;
while($i<$numOfFilesInC)
{
print("$i. $filesInC[$i]<br>");
$i++;
}
print("</html>");
//done
?>

Expected result:
----------------
Files in C:\

hello.txt
randomfile.htm
randomfile.whatever
windows
documents and settings
program files

Actual result:
--------------
Parse error: parse error, unexpected T_VARIABLE in /drive2/fpgshttpd/darkjedi3/Anti-Virus/open.php on line 9


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-03-09 07:03 UTC] dave@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Even if you think it is not a bug, we often know better than you,
please consult the support channels first before even considering
to reopen this report.

Thank you for your interest in PHP.

This is not a bug. Contact php-general@lists.php.net with your issue.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jul 04 00:05:44 2022 UTC