php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32136 Client connection time exceeds
Submitted: 2005-02-28 20:22 UTC Modified: 2005-03-07 17:36 UTC
From: mail at brungs-peter dot de Assigned: dmitry (profile)
Status: Closed Package: SOAP related
PHP Version: 5.0.3 / 5.1.0-dev OS: Windows XP SP2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mail at brungs-peter dot de
New email:
PHP Version: OS:

 

 [2005-02-28 20:22 UTC] mail at brungs-peter dot de
Description:
------------
The error occurs, when I test a Client / Server Connection with Soap ( Built in PHP) and a WSDL file.

The result is:

Fatal error: Maximum execution time of 30 seconds exceeded in C:\Projekte\WebRoot\PHP\Soap_Test\StockClient.php on line 9

Reproduce code:
---------------
Sample from http://www.zend.com/php5/articles/php5-SOAP.php?print=1

with:

<?php
	$quotes = array( "ibm" => 98.42 );  

	function getQuote($symbol) {
		global $quotes;
		return $quotes[$symbol];
	}

	//ini_set("soap.wsdl_cache_enabled", "0"); // disabling WSDL cache
	$server = new SoapServer("StockQuote.wsdl");
	$server->addFunction("getQuote");
	$server->handle();
?> 

  <?php
  $client = new SoapClient("StockQuote.wsdl");
  
  try {
	print($client->getQuote("ibm"));
  } catch ( SoapFault $exception) {
	echo $exception;
  }
?> 

Expected result:
----------------
98.42 

Actual result:
--------------
Fatal error: Maximum execution time of 30 seconds exceeded in C:\Projekte\WebRoot\PHP\Soap_Test\StockClient.php on line 9

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-02-28 20:24 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip


 [2005-03-01 17:16 UTC] mail at brungs-peter dot de
Hallo,

I have updated to versionPHP/5.1.0-dev. I have still
this error.

Maybe here is one more information:

libxml

libXML support => active
libXML Version => 2.6.11
libXML streams => enabled

and

SoapFault exception: [HTTP] Could not connect to host in C:\Projekte\WebRoot\PHP\Soap_Test\stockclient.php:5
Stack trace:
#0 C:\Projekte\WebRoot\PHP\Soap_Test\stockclient.php(5): SoapClient->__call('<?xml version="...', 'http://localhos...',
'urn:xmethods-de...', 1)
#1 C:\Projekte\WebRoot\PHP\Soap_Test\stockclient.php(5): SoapClient->getQuote('getQuote', Array)
#2 {main}NULL

I hope this information can help.

Greetings

Peter
 [2005-03-05 13:38 UTC] dmitry@php.net
You just cannot connect to soap server.
Probably it is down or it's URL is invalid.
 [2005-03-07 17:35 UTC] mail at brungs-peter dot de
I have tested again.
I general, the Soap procedure work better with 5.1.0 than 5.0.3., because some unchanged sources are worked after the
update. 

The described problem is now also working. See below.

Thanks for your help.

WSDL-Endpoint:
<!-- Endpoint definition -->
<service name="StockQuoteService">
<port name="StockQuotePort" binding="tns:StockQuoteBinding">
<soap:address location="http://127.0.0.1/php/Soap_Test/StockServer.php"/>
</port>
</service>
 [2005-03-07 17:36 UTC] mail at brungs-peter dot de
OK
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Apr 19 22:01:28 2024 UTC