php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3203 not detected parser error: hangs the httpd which is answering
Submitted: 2000-01-13 12:36 UTC Modified: 2002-10-01 11:24 UTC
From: maurice dot szmurlo at info dot unicaen dot fr Assigned:
Status: Not a bug Package: Parser error
PHP Version: 3.0.14 OS: linux redhat 6.1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: maurice dot szmurlo at info dot unicaen dot fr
New email:
PHP Version: OS:

 

 [2000-01-13 12:36 UTC] maurice dot szmurlo at info dot unicaen dot fr
php version: 4b3 (ok, its a beta...)
compiled with gd, latest version

code: ('$' missing in loop termination test)
<?
for($i=0; i<10; $i++)
  echo($i."<br>\n");
?>

the error is not detected and makes the interpreter run for ever
solution: kill and restart the http daemon

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-01 11:24 UTC] hholzgra@php.net
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit http://www.php.net/support.php

Thank you for your interest in PHP.

if you had E_NOCTICE error messages activated
you would have seen that i is interpreted as
string "i" as no constant by the name i is 
definend

and i is less then 10 when auto-conversion is
applied

PS: you should consider setting max_execution_time
to prevent scripts hanging in endless loops
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Aug 20 23:01:34 2019 UTC