php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31921 new COM() crashes PHP
Submitted: 2005-02-11 00:46 UTC Modified: 2005-02-11 01:30 UTC
From: ceefour at gauldong dot net Assigned:
Status: Not a bug Package: COM related
PHP Version: 4.3.10 OS: Windows XP SP1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ceefour at gauldong dot net
New email:
PHP Version: OS:

 

 [2005-02-11 00:46 UTC] ceefour at gauldong dot net
Description:
------------
$x = new COM("Word.Application") crashes PHP
It crashes even without a web server (i.e. running PHP from command line).

$x = com_load("Word.Application") works fine though.

It's impossible to get a backtrace since PHP crashes when executing the new COM() line.

$x =& new COM(...) doesn't crash PHP, but the returned object is usable. I guess this is the "intended" behavior since COM objects shouldn't be passed by reference.

Reproduce code:
---------------
1. $x = new COM("Word.Application")
2. $x = com_load("Word.Application")

Expected result:
----------------
1. COM object
2. COM object

Actual result:
--------------
1. php crashes
2. COM object (works fine)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-02-11 01:30 UTC] edink@php.net
Duplicate.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 01 20:05:53 2022 UTC