php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31910 A special string containing "E" causes an Unhandled Exception
Submitted: 2005-02-10 10:23 UTC Modified: 2005-04-07 01:00 UTC
Votes:7
Avg. Score:3.6 ± 1.4
Reproduced:7 of 7 (100.0%)
Same Version:2 (28.6%)
Same OS:5 (71.4%)
From: jakub at icewarp dot com Assigned:
Status: No Feedback Package: Scripting Engine problem
PHP Version: 4CVS-2005-02-10 OS: win32 / ISAPI
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jakub at icewarp dot com
New email:
PHP Version: OS:

 

 [2005-02-10 10:23 UTC] jakub at icewarp dot com
Description:
------------
Hi
This problem happens only in the 4.3.11 dev version.
It is 100% reproducable. See the code below. It will produce the following error:

PHP has encountered an Unhandled Exception Code -1073741679 at 011171E3

The problem must be that PHP thinks it's a real number or something. It didn't occur in previous versions. Please, try to fix it.

Cheers
Jakub

Reproduce code:
---------------
<?
  $file = "20050131014110E312-00000002.tmp";
  $file != ".";
?>

Actual result:
--------------
PHP has encountered an Unhandled Exception Code -1073741679 at 011171E3

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-02-10 14:43 UTC] sniper@php.net
What might have been the configure line you used?
I can _not_ reproduce this with latest CVS version of PHP_4_3 branch nor with HEAD (upcoming PHP 5.1 branch).



 [2005-02-10 15:02 UTC] jakub at icewarp dot com
I'm testing PHP for Windows. I've just tested 4.3.10 and it has the same problem. 4.3.8 does suffer from this problem.
I doubt it has anything with ISAPI or other PHP interface. If you test PHP on windows it is 100% reproducable. I have colleagues who reported the same problem on different machines.

I'm not sure what you mean by configure line. The PHP.INI is the default one shipped with PHP.

The question is why did it change. It must have been the version 4.3.9 or 4.3.10 that changed something. If you prepend an alphabet character before the string it will not occur.

Colleagues believe the "E" stands for an exponent or similar. Let me know how I can help
 [2005-02-10 15:04 UTC] sniper@php.net
Updated OS field to be correct. Works fine on *nix.

 [2005-02-11 03:31 UTC] sniper@php.net
I can _not_ reproduce this on windows using Debug build of CLI binary.

 [2005-02-11 03:35 UTC] sniper@php.net
I can _not_ reproduce this with the latest CVS snapshot build for win32 either. (still using CLI)


 [2005-02-11 03:40 UTC] sniper@php.net
And I can not reproduce this with Apache2 SAPI either..
So please tell me HOW to reproduce this?

 [2005-02-11 10:13 UTC] jakub at icewarp dot com
I did some more tests and it is true I could not reproduce it in command line using php.exe (CGI). It is a subject of the ISAPI interface only then. Did you test ISAPI?
 [2005-02-14 21:17 UTC] plyrvt at mail dot ru
"PHP has encountered an Unhandled Exception Code %d at %p"
it's a part of php4isapi.dll file, but I cannot reproduce this bug neither under 4.3.8 nor 4.3.9 nor 5.0.2 (winxp-sp1-iis5.1)
 [2005-02-14 21:48 UTC] plyrvt at mail dot ru
Maybe this is related somehow to 
4.3.10 Changelog: "Added the %F modifier to *printf to render a non-locale-aware representation of a float with the . as decimal separator."
and is locale-dependent?
 [2005-02-15 07:39 UTC] jakub at icewarp dot com
Yes it might be that... I can reproduce it since 4.3.10.
 [2005-02-15 10:51 UTC] tony2001@php.net
If you think it might be that, than what's your locale?
Nobody can reproduce it except you, so just don't sit & wait - run the code on another winblows box, try to get more info etc.
 [2005-02-15 10:59 UTC] jakub at icewarp dot com
It occurs on all Windows locales US, CZ. Reproduced it on W2000 and WXP. Please, try 4.3.10 or later
Thank you
 [2005-02-27 13:38 UTC] milan dot rippel at gmail dot com
Hi guys,
I just tried the code Jakub posted above and I am really getting the same error - running PHP 4.3.10.

I wonder why you don't get the same one :-(.

Can someone take one more look on it?

Milan
 [2005-04-07 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2005-12-12 17:23 UTC] milanrippel at seznam dot cz
Tested with PHP 4.4.1 with the same code:

<?
  $file = "20050131014110E312-00000002.tmp";
  $file != ".";
?>

The same error is given. When you compare strings with "E" in it then this "E" is taken as exponent - not as a character.

reproduced only in ISAPI mode - FCGI runs fine on LInux.

Can anyone take a look on it?

Milan
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Oct 06 15:05:53 2022 UTC