php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31901 Configure fails with curl 7.12.3 / 7.13.0
Submitted: 2005-02-09 16:42 UTC Modified: 2005-02-09 17:25 UTC
From: minnoce at polito dot it Assigned:
Status: Closed Package: *Configuration Issues
PHP Version: 4.3.10 OS: Linux RH 7-3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: minnoce at polito dot it
New email:
PHP Version: OS:

 

 [2005-02-09 16:42 UTC] minnoce at polito dot it
Description:
------------
Attempting to configure PHP with libcurl with:

./configure --with-curl=/services/curl

where "/service/curl" is the path for my libcurl installation.

The configure stops with:

checking for CURL support... yes
checking for cURL 7.9.8 or greater... ./configure: curl-config: command not found
configure: error: cURL version 7.9.8 or later is required to compile php with cURL support

Looking in the configure script for the code testing CURL, I see:
(line 20151) if ${CURL_DIR}/bin/curl-config --libs print > /dev/null 2>&1; then

That's the problem:
the curl-config program don't like "print" command, and omitting it:
(line 20151 modified) if ${CURL_DIR}/bin/curl-config --libs > /dev/null 2>&1; then

all work fine!

The same bug is present in PHP 5.0.3 configure.

Thanks,
Mauro


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-02-09 17:25 UTC] rasmus@php.net
Also tested and confirmed with curl-7.10.x.

Fixed in CVS
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Jul 18 17:01:29 2024 UTC