php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31852 /functions returns functions.js on some mirrors
Submitted: 2005-02-05 13:44 UTC Modified: 2007-03-29 16:41 UTC
Votes:4
Avg. Score:3.5 ± 0.9
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: mazzanet at mazzanet dot id dot au Assigned: bjori (profile)
Status: Closed Package: Website problem
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mazzanet at mazzanet dot id dot au
New email:
PHP Version: OS:

 

 [2005-02-05 13:44 UTC] mazzanet at mazzanet dot id dot au
Description:
------------
On the mirrors au, au2, fi, fi2, id2, ie2, lv, nl3, no, sg2, es, ch2, th, th2, uk2 and us4, the /functions shortcut returns the contents of functions.js

Reproduce code:
---------------
http://[affected mirrors].php.net/functions

Expected result:
----------------
The Functions doc page

Actual result:
--------------
Contents of functions.js

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-05-24 00:02 UTC] mazzanet@php.net
For the same mirrors, /print returns the contents of /print.css as well.
So effectively, on these mirrors any URL shortcut that mostly matches (eg. print -> print.css, functions -> functions.js) a file in the web root, the contents of the file is always returned.
 [2005-06-11 14:26 UTC] mazzanet@php.net
After some examination (thanks erigol), it appears the cause of this is not disabling MultiViews in the Apache configuration of these mirrors.
To fix this, the listed mirrors need to re-read the mirroring guidelines and have the following line in their Apache configuration:
"Options -Indexes -Multiviews"
 [2005-06-13 08:59 UTC] mazzanet@php.net
Re-opening.
MultiViews may fix some of the listed mirrors but not all.
After some discussion with a mirror admin and some experiments, one of the mirrors affected (us4) fixed itself overnight without any user input.

Affected mirrors all send the following in the headers: (for requesting /print)
TCN: choice
Vary: negotiate
Content-location: /print.css 

This indicates some form of content negotiation.
us4 which "magically fixed itself overnight" is now sending:
TCN: choice
Vary: Cookie
Content-location is missing.


 [2005-09-23 10:46 UTC] sniper@php.net
Still happening at least with the fi mirror, fi2 doesn't seem to be quite operational atm.

 [2006-04-22 04:41 UTC] mazzanet@php.net
This bug is still occuring :/
From the very little time I've looked at it, I still can't work out what the heck is causing this.
 [2006-09-28 14:40 UTC] bjori@php.net
We need to add this to our mirror-test script..
 [2007-03-29 16:41 UTC] bjori@php.net
This bug has been fixed in CVS. Since the websites are not directly
updated from the CVS server, the fix might need some time to spread
across the globe to all mirror sites, including PHP.net itself.

Thank you for the report, and for helping us make PHP.net better.

Added /functions as a test case to our mirror-test-bot
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Mar 05 04:01:29 2024 UTC