|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31802 ftp_get never downloads a file
Submitted: 2005-02-02 04:16 UTC Modified: 2007-11-07 20:25 UTC
From: neo_in_matrix at msn dot com Assigned:
Status: No Feedback Package: FTP related
PHP Version: 4.3.10 OS: Fedora Core 1 & 3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
Solve the problem:
22 + 14 = ?
Subscribe to this entry?

 [2005-02-02 04:16 UTC] neo_in_matrix at msn dot com
I have a small script file (less than 200 lines) that pulls Firefox/Thunderbird nightly trunk from The script works well on Windows 2000 family since it was created in May 2003.

I got my feet into Linux about half year ago. I had once tried to modify the script to let it work under Fedora Core 1; but I failed. ftp_get never download a file successfully. I think I was using an old version in PHP 4.3x series. 

I recently installed Fedore Core 3 and tried to do it again, since I think I am getting more experience on Linux. But, I get the same failure.

It *seems* (no accurate proof) that ftp_get creates a zero byte file and never downloads and writes bytes to the file. I see this by doing ls -l.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2005-02-02 17:02 UTC]
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc.

If possible, make the script source available online and provide
an URL to it here. Try to avoid embedding huge scripts into the report.

 [2005-02-21 19:57 UTC]
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun May 26 09:01:32 2024 UTC