php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #31778 there's a broken URL on your site.
Submitted: 2005-01-31 15:15 UTC Modified: 2005-01-31 16:45 UTC
From: mike at openconcept dot ca Assigned:
Status: Closed Package: Documentation problem
PHP Version: 4.3.10 OS: your site
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mike at openconcept dot ca
New email:
PHP Version: OS:

 

 [2005-01-31 15:15 UTC] mike at openconcept dot ca
Description:
------------
Hi Mike,

Please report documentataion problems as documentation bugs in the bug system.

On this page:
http://ca.php.net/manual/en/ref.domxml.php
In this paragraph:
"This PECL extension is not bundled with PHP. Additional information such as new releases, downloads, source files, maintainer information, and a CHANGELOG, can be located here: http://pecl.php.net/package/domxml. "
The link to:
http://pecl.php.net/package/domxml
is really busted.
Would also be really good to include a simpler way to install this.  Such as:
# yum install php-domxml
Not that everyone can use yum, but sure would be nice to know that there is a simple way to install this in  many Linux distros.

We do have a complete section on installing PECL extensions in the manual. Possible simpler methods need to be documented there.

Regards,
Gabor Hojtsy


Reproduce code:
---------------
Go here:
http://ca.php.net/manual/en/ref.domxml.php

Expected result:
----------------
Install instructions

Actual result:
--------------
404

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-01-31 15:23 UTC] mez@php.net
I'm not too sure whether this fits in with a documentation problem or not. It seems though that there is no such PECL package at all... so I'll just set this as verified for now :D
 [2005-01-31 16:45 UTC] philip@php.net
The link was already fixed (PHP Bug #31724) and regarding Yum... yum, apt-get, feta, fink, etc. are not PECL specific and since a ton of install wrappers exist out there I don't think listing a few is necessary, or a good idea. It would also require we keep track of which PHP extensions are and are not installable via all these methods, and we'd rather not support them as official means.

For good measure, here's a link to various package managers:
http://www.linuxlinks.com/Software/Utilities/Packagers/ 
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Fri Feb 03 16:03:49 2023 UTC