php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31735 COM will not create an object
Submitted: 2005-01-28 04:41 UTC Modified: 2005-02-10 23:32 UTC
Votes:3
Avg. Score:4.3 ± 0.5
Reproduced:3 of 3 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: jbricci at gmail dot com Assigned:
Status: No Feedback Package: COM related
PHP Version: 4.3.10 OS: Win2000
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: jbricci at gmail dot com
New email:
PHP Version: OS:

 

 [2005-01-28 04:41 UTC] jbricci at gmail dot com
Description:
------------
Trying to create a object via COM, will not create any object, no matter what COM type dll is called!

Reproduce code:
---------------
<?

	$next = $_GET['next'];
	$key = new COM ( 'WScript.Shell' );
	$key->RegWrite ( 'HKEY_LOCAL_MACHINE\SOFTWARE\ABCSpell\LicenseKey', $next, 'REG_DWORD' );
	$key = null;

?>

Expected result:
----------------
I expect the object to be created and the value entered into the Windows registry!

Actual result:
--------------
[27-Jan-2005 21:54:54] PHP Fatal error:  Call to a member function on a non-object in E:\www\docs\www\docs\run.php on line 5

If I try to test if it is a object, after trying to create it...

<?

if ( !is_object ( $key ) )
{
	echo 'is not a object';
}

?>

It will always print 'is not a object', this happens for any COM object I try -> (word, mappoint, spell)! Going back to 4.3.9, everything works the way it should!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-02-10 23:32 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2008-10-04 23:48 UTC] pykker at gmail dot com
Confirmed.

I have the same problem with PHP 5.2.1 and 5.2.6 on Windows Vista 
SP1.

Any news about this?
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Aug 18 07:01:28 2019 UTC