php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31639 mysql error code constant not defined
Submitted: 2005-01-21 16:17 UTC Modified: 2005-01-21 20:34 UTC
From: mnemo at minimum dot se Assigned:
Status: Not a bug Package: MySQL related
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
29 - 25 = ?
Subscribe to this entry?

 
 [2005-01-21 16:17 UTC] mnemo at minimum dot se
Description:
------------
the constant CR_CONNECTION_ERROR is not defined.

this works:
if (mysql_errno() == 2002) { blah }

but this does not:
if (mysql_errno() == CR_CONNECTION_ERROR) { blah }


see, http://dev.mysql.com/doc/mysql/en/Error-handling.html


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-01-21 17:36 UTC] georg@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

PHP doesn't use and support mysql's internal error 
constants. 
 [2005-01-21 20:34 UTC] mnemo at minimum dot se
Aha I understand, sry for the confusion.


From this page (see below) there is a "see also" link which points to those constants.

http://se.php.net/manual/en/function.mysql-errno.php

I realize now that the link goes to the MySQL site however I did not realize this when I first met this problem.

Maybe a little note can be added besides this link, something like:

"Note: Make sure you use the actual error code integers not the constants because the constants listed in this document is not defined in PHP's MySQL-library."
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Apr 01 15:03:39 2023 UTC