php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31628 fopen with URL fails when page requires authentication
Submitted: 2005-01-20 20:46 UTC Modified: 2005-01-20 23:28 UTC
From: bbockholt at yahoo dot com Assigned:
Status: Not a bug Package: URL related
PHP Version: Irrelevant OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bbockholt at yahoo dot com
New email:
PHP Version: OS:

 

 [2005-01-20 20:46 UTC] bbockholt at yahoo dot com
Description:
------------
If fopen on a URL returns a warning that 
says it succeeded, but the handle is bad,
perhaps the URL requires authentication?

Seems self-evident, but, you know...it stumped
me for a bit.

This is not a bug, but wasn't mentioned 
in the documentation or anywhere I looked.


Reproduce code:
---------------
fopen('http://www.somedom.com/auth/reqd.php', 'r');


Expected result:
----------------
The page content.

Actual result:
--------------
Warning: file("http://www.somedom.com/auth/reqd.php") - Success in /var/www/html/test/reqd.php on line 2


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-01-20 23:28 UTC] edink@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 24 04:03:36 2021 UTC