|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3161 Segmentaion Fault with Sybase-CT Support
Submitted: 2000-01-10 13:58 UTC Modified: 2000-02-10 15:23 UTC
From: straub at i-netpartner dot de Assigned:
Status: Closed Package: Sybase-ct (ctlib) related
PHP Version: 4.0 Latest CVS (10/01/2000) OS: Linux 2.2.10 -- SuSE 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
28 - 24 = ?
Subscribe to this entry?

 [2000-01-10 13:58 UTC] straub at i-netpartner dot de
When i compile php4 with sybase-ct support (Client form the SuSE CD) I get a Segmentation Fault when I'm going to start it. Here's the output of gdb:

GNU gdb 4.18
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu"...
(gdb) -X
Undefined command: "-X".  Try "help".
(gdb) run -X
Starting program: /usr/src/apache_1.3.9/src/httpd -X

Program received signal SIGSEGV, Segmentation fault.
0x4029ed1d in main_arena () from /lib/


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2000-01-10 14:10 UTC] straub at i-netpartner dot de
I've compiled it as apache module 
	--with-apache=/usr/src/apache_1.3.9 \
 [2000-01-12 06:01 UTC] straub at i-netpartner dot de
Here is the needed output from gdb. I hope someone can locale this fault
(gdb) bt
#0  0x4029ed1d in main_arena () from /lib/
#1  0x401f68ac in buffered_vfprintf (s=0x4029ec80,
    format=0xbfffe254 "\n\nThe context allocation routine failed when it tried to load localization files!!\n", args=0xbfffe230) at vfprintf.c:1756
#2  0x401f17e6 in _IO_vfprintf (s=0x4029ec80,
    format=0xbfffe254 "\n\nThe context allocation routine failed when it tried to load localization files!!\n", ap=0xbfffe230) at vfprintf.c:1018
#3  0x401fa2d1 in fprintf (stream=0x4029ec80,
    format=0xbfffe254 "\n\nThe context allocation routine failed when it tried to load localization files!!\n") at fprintf.c:32
#4  0x4006ba68 in com_perr () from /opt/sybase/lib/
#5  0x40068c45 in com_intl_verify_ctxloc () from /opt/sybase/lib/
#6  0x400d97bc in cs_ctx_alloc () from /opt/sybase/lib/
#7  0x80e4f27 in php_minit_sybase (type=1, module_number=18)
    at php_sybase_ct.c:231
#8  0x809088d in zend_startup_module (module=0x8186920) at zend_API.c:677
#9  0x807c418 in php_startup_extensions (ptr=0x81834ec, count=25) at main.c:843
#10 0x807d06f in php_startup_internal_extensions () at internal_functions.c:101
#11 0x807c678 in php_module_startup (sf=0x8180500) at main.c:984
#12 0x807b5ab in php_init_handler ()
#13 0x80fe639 in ap_init_modules ()
#14 0x8109c4d in main ()
#15 0x401c3213 in __libc_start_main (main=0x8109890 <main>, argc=2,
---Type <return> to continue, or q <return> to quit---
    argv=0xbffff7f4, init=0x805eb70 <_init>, fini=0x814c3a0 <_fini>,
    rtld_fini=0x4000ac30 <_dl_fini>, stack_end=0xbffff7ec)
    at ../sysdeps/generic/libc-start.c:90
 [2000-02-01 10:47 UTC] joey at cvs dot php dot net
Provide a sample script? Also, what is the environment var $SYBASE set to for the user that starts/runs apache+php?
 [2000-02-10 15:23 UTC] straub at i-netpartner dot de
I had a problem with the locales settings. The default system language
is defined in LC_ALL as "de_DE" and for this is no locales file in the
standard. I had to install the language support package and 
create a directorie for de_DE. 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 08 17:05:52 2022 UTC