php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31568 Extensions do not recognize needed files in PATH
Submitted: 2005-01-16 09:26 UTC Modified: 2005-01-18 10:07 UTC
From: chris at epliant dot com Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 5.0.3 OS: Windows XP Professional SP2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: chris at epliant dot com
New email:
PHP Version: OS:

 

 [2005-01-16 09:26 UTC] chris at epliant dot com
Description:
------------
This is a new install of PHP 5.0.3.  I am following the instructions to try to centralize all files in the PHP dirs rather than copying supporting files to C:\WINDOWS\SYSTEM32.

I added C:\php5 to system PATH.
Copied libmysql.dll to C:\php5\ from C:\mysql\lib\opt\.
libeay32.dll and ssleay32.dll already existed in C:\php5
I enabled the curl, mysql, and/or  mysqli extensions.

The only location that the Apache module will recognize the above files is C:\WINDOWS\SYSTEM32.

Reproduce code:
---------------
php.ini lines:
--------------------------------
extension_dir = "c:/php5/ext/"

extension=php_curl.dll
extension=php_mysql.dll
extension=php_mysqli.dll
--------------------------------

Code:
--------------------------------
<?php
   phpinfo();
?>
--------------------------------


Expected result:
----------------
Start apache and expect phpinfo() to report the presence of curl and mysql and/or mysqli (I tried it with either one, then both enabled).



Actual result:
--------------
Apache generated warning windows and phpinfo() does not report mysql or curl.

In starting apache-2.0.52, I get:
PHP Startup: Unable to load dynamic library 'c:\php5\ext\php_mysql.dll' - The specified module could not be found.

In starting apache-2.0.52, I get:
PHP Startup: Unable to load dynamic library 'c:\php5\ext\php_curl.dll' - The specified module could not be found.


(When I copied all three of the above files to C:\Windows\System32, Apache worked properly but defeats the purpose).

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-01-18 10:07 UTC] chris at epliant dot com
Found problem with my operating system.  This is not a bug.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Fri Dec 01 04:01:29 2023 UTC