php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31524 Can't Compile --with-imap
Submitted: 2005-01-13 00:29 UTC Modified: 2005-01-13 21:52 UTC
From: shadda at gmail dot com Assigned:
Status: Not a bug Package: IMAP related
PHP Version: 5.0.3 OS: Knoppix Debian (Linux)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
7 + 28 = ?
Subscribe to this entry?

 
 [2005-01-13 00:29 UTC] shadda at gmail dot com
Description:
------------
I have tried this in multiple versions of php5, including several snapshots. I've also done so with different IMAP C-Client versions, also with different snapshots. 

I've compiled the C-Client and placed it in correct locations, as well as setup the actuall IMAP and POP3 server on my system.

IMAP *.c files located in /usr/local/imap-2004b/lib/
IMAP *.h files located in /usr/local/imap-2004b/include/

The c-client.a and libc-client.a files are also in lib/, (I have also tried using symlinks instead of actuall copy when creating libc-client.a, but that didn't work  either)

I trimmed my ./configure line down, and narrowed the problem specifically to imap. I can compile with any other extension of my choosing but this one.

./configure --with-apxs2=/var/www/bin/apxs --with-imap=/usr/local/imap-2004b

Results in a configure error that tells me to check the config.log file.

I do so, and I see that the failed operation was #include confdefs.h

confdefs.h is part of the package i'm installing (PHP5) and i cannot see it not being found, just because i'm compiling --with-imap. 

I consulted several debian forums and IRC channels, as well as EFNet #PHP, and no one was able to solve this problem.

I also did a thorough search of google and bugs.php.net but found nothing similar to this problem. 

I have recompiled IMAP four times now, but it still does it.

When running ./configure statement, it runs fine until i


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-01-13 00:35 UTC] shadda at gmail dot com
err Okay, bug report was trimmed for some reason (?)

It runs fine until it gets to Checking Whether IMAP Support Works.....no

then sprouts the error, and tells me to check the log.

I will paste the log here if need be. Thanks.
 [2005-01-13 08:11 UTC] derick@php.net
Please put that log somewhere online and provide a link... it's too large to be pasted here.
 [2005-01-13 20:03 UTC] shadda at gmail dot com
UPDATE: Okay, it seems that IMAP-2004b was compiling with OpenSSL support *even after telling it explicitly not to* and that was the reason why it would not compile. 

Still at a loss why it was reporting problems with confdefs.h, but i guess this falls under "C-Client" bugs.

Thanks for your time, I have it working now.
 [2005-01-13 21:52 UTC] johannes@php.net
No PHP Bug -> Bogus 
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 18 19:05:43 2022 UTC