php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31511 MSSQL queries generate error: "Changed database context to (dbname)"
Submitted: 2005-01-12 11:41 UTC Modified: 2005-01-12 12:59 UTC
From: Arne dot Heizmann at csr dot com Assigned:
Status: Closed Package: MSSQL related
PHP Version: 4.3.10 OS: Windows Server 2003
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Arne dot Heizmann at csr dot com
New email:
PHP Version: OS:

 

 [2005-01-12 11:41 UTC] Arne dot Heizmann at csr dot com
Description:
------------
I have upgraded a company-internal website from PHP 4.3.9 to PHP 4.3.10 and I am now getting the following error for just about any INSERT or UPDATE query I send to the MS SQL database:

    Changed database context to '(dbname)'.

Where (dbname) is, of course, the name of the DB.

I believe that this is a duplicate of 31372; however, 31372 was closed "Bogus" but I do believe that this is a real problem, and I couldn't find a way of re-opening that other bug. A comment also says that it is a duplicate, but doesn't say what bug it is a duplicate of (and I searched for it and couldn't find it). I've also noticed 31195, but it didn't mention this error message, so I don't know if it's the same problem.

Expected result:
----------------
Queries that succeed in PHP 4.3.9 should equally succeed in PHP 4.3.10.

Actual result:
--------------
Queries fail with "Changed database context" error message.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-01-12 12:59 UTC] Arne dot Heizmann at csr dot com
Thanks; that CVS snapshot seems to work.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Oct 06 13:05:53 2022 UTC