php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31457 failed to compile --with-xsl missing -lgcrypt?
Submitted: 2005-01-09 18:50 UTC Modified: 2005-01-09 23:58 UTC
From: hendlerman at yahoo dot com Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 5.0.3 OS: Fedora Core 3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: hendlerman at yahoo dot com
New email:
PHP Version: OS:

 

 [2005-01-09 18:50 UTC] hendlerman at yahoo dot com
Description:
------------

CONFIGURE LINE
./configure --with-apsx2="/usr/sbin/apxs" --with-mysql --with-ldap --with-zlib  --enable-magic-quotes  --with-mcrypt  --with-mhash --enable-calendar   --enable-sockets --with-xsl

results
 error can not find
-lgcrypt
5.03 compile bug http://www.codecomments.com/PHP_Installation/message345340.html



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-01-09 19:47 UTC] tony2001@php.net
Please, figure out the library that requires libgcrypt, as it seems that this issue is only reproducible with FC.
Also see #31104, this bug describes the very same problem.
 [2005-01-09 20:08 UTC] hendlerman at yahoo dot com
I believe --with-xsl allowed it to pass that fail point.
I am not currently on the fedora system and can not reproduce the problem at this time.
 [2005-01-09 20:19 UTC] tony2001@php.net
I can't reproduce it too, so just leave this bug as waiting for feedback until someone add more info about it.
 [2005-01-09 21:54 UTC] rrichards@php.net
New libxslt rpms require libgcrypt (so install libgcrypt-devel)
 [2005-01-09 22:13 UTC] tony2001@php.net
Why not to add an appropriate check to config.m4 then?
 [2005-01-09 23:58 UTC] rrichards@php.net
It depends upon how libxslt is compiled. For fedora, its built with libgcrypt, so they should add the dependency in the rpm.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Feb 19 16:01:32 2020 UTC