php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31438 mssql_query always returns FALSE
Submitted: 2005-01-07 12:21 UTC Modified: 2005-01-07 16:30 UTC
From: klaus dot kuehne at gga-hannover dot de Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 4.3.10 OS: Windows 2000 Server
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: klaus dot kuehne at gga-hannover dot de
New email:
PHP Version: OS:

 

 [2005-01-07 12:21 UTC] klaus dot kuehne at gga-hannover dot de
Description:
------------
Hello,

after upgrading 4.3.6 to 4.3.10, many of out scripts failed. The reason: On executing INSERT/DELETE/UPDATE-operations, mssql_query() returns FALSE, even if the statement was o.k. and executed correctly.

Example:
...
$sql = "delete from TAB where [KEY] = 117";
$ret = mssql_query($sql, $con);
if (!$ret) die("Operation Failed");
...

However, the DELETE operation was successful: record 117 was removed from the table.

After returning to PHP 4.3.6, all scripts are running correctly.

Regards,

Klaus K?hne, GGA Institute, Hannover, Germany


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-01-07 12:48 UTC] sniper@php.net
Already reported by someone else (use search before submitting new reports!!!) and also FIXED in CVS.

 [2005-01-07 16:30 UTC] klaus dot kuehne at gga-hannover dot de
Shot and killed ...
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Apr 15 03:01:28 2024 UTC