php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31372 php_mssql.dll generates error despite the query is correct.
Submitted: 2005-01-01 15:03 UTC Modified: 2005-01-01 16:47 UTC
From: captain5ive at yahoo dot com Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 4.3.10 OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: captain5ive at yahoo dot com
New email:
PHP Version: OS:

 

 [2005-01-01 15:03 UTC] captain5ive at yahoo dot com
Description:
------------
Using php_mssql.dll when you query Microsoft SQL Server 2000, mssql returns the following informational message.

Changed database context to 'SampleDB'.

This is not an error but the new mssql extension returns error. Every php application that works with SQL Server now encounter this bug if they handle errors.

Reproduce code:
---------------
  $link = mssql_connect("server", "sa", "");
  mssql_select_db("SampleDB", $link);
  mssql_query("DELETE FROM SampleTable WHERE id=10", $link) or die(mssql_get_last_message());


Expected result:
----------------
No error must be returned because everything is ok.

Actual result:
--------------
The following error is returned.

Changed database context to 'SampleDB'.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-01-01 16:47 UTC] derick@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Jan 16 19:03:36 2022 UTC