php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31365 the multiple dimension arrays are not diplayed correctly via echo
Submitted: 2004-12-31 11:33 UTC Modified: 2004-12-31 12:24 UTC
From: rm_dani at yahoo dot com Assigned:
Status: Not a bug Package: Output Control
PHP Version: 5.0.3 OS: windows XP sp2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rm_dani at yahoo dot com
New email:
PHP Version: OS:

 

 [2004-12-31 11:33 UTC] rm_dani at yahoo dot com
Description:
------------
just test the followings:

$bug[0][0] = "Bug in PHP4.0.4";
echo "Display the bug: $bug[0][0]";
echo "Display the bug: ". $bug[0][0];


I doubt that's a feature:D

Kind regards,
Daniel

Reproduce code:
---------------
$bug[0][0] = "Bug in PHP4.0.4";
echo "Display the bug: $bug[0][0]";
echo "Display the bug: ". $bug[0][0];


Expected result:
----------------
Display the bug: Bug in PHP4.0.4
Display the bug: Bug in PHP4.0.4

--------------------

the PHP4.0.4 string is due to the original version of PHP I was using and I've discovered it...


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-12-31 11:40 UTC] rm_dani at yahoo dot com
I change the title of the bug cause it's happening for all the arrays with multiple dimensions
 [2004-12-31 12:24 UTC] derick@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Apr 15 20:01:39 2024 UTC