php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31294 Wrong charset
Submitted: 2004-12-25 14:48 UTC Modified: 2005-03-21 11:03 UTC
From: megabrain at fight-club dot ru Assigned: edink (profile)
Status: Not a bug Package: MySQL related
PHP Version: 5.0.3 OS: Windows 2003
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: megabrain at fight-club dot ru
New email:
PHP Version: OS:

 

 [2004-12-25 14:48 UTC] megabrain at fight-club dot ru
Description:
------------
I dont know wy it happens..
Trivia:
MySQL 4.1.8
Base with CP1251 support
PHP 5.0.3
Loaded mysql (not mysqli) extensions..

Any queries to base returns "?" where russian chars in base..

version 5.0.2 dont have this problems 

But under Apache2 with php loaded as module no problems too..


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-12-28 11:01 UTC] megabrain at fight-club dot ru
example:
php 5.0.2
$result=mysql_query("select ru_name from mtable");
$runame=mysql_result($result,0,"ru_name");
print $runame;

output: ????

php 5.0.3
$result=mysql_query("select ru_name from mtable");
$runame=mysql_result($result,0,"ru_name");
print $runame;

output: ????

database is UTF8
 [2005-02-28 21:13 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip


 [2005-03-14 06:19 UTC] megabrain at fight-club dot ru
Same problem with CVS build
 [2005-03-20 23:12 UTC] sniper@php.net
Edin: did you by any chance change the settings/version for the mysql client libs between 5.0.2 and 5.0.3 ?

 [2005-03-21 11:03 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

This is not a bug in PHP, you just need to fix your configuration.

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Oct 05 06:05:53 2022 UTC