php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3128 Installation with mcrypt failed
Submitted: 2000-01-06 17:59 UTC Modified: 2000-01-08 11:27 UTC
From: markus at rebbert dot de Assigned:
Status: Closed Package: Installation problem
PHP Version: 3.0.13 OS: Linux (SuSE 6.3)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: markus at rebbert dot de
New email:
PHP Version: OS:

 

 [2000-01-06 17:59 UTC] markus at rebbert dot de
After I have compiled Version 3.0.13 with sybase evrything works fine.  If  I compile with sybase and MCRYPT (Lib-Version 2.2.4) I can 't restart the apache(Version 1.3.9). I get an Segmentation Fault. 

Help? 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-01-08 06:24 UTC] sas at cvs dot php dot net
You need to configure mcrypt with --disable-pthreads to make it work.
 [2000-01-08 11:27 UTC] markus at rebbert dot de
sorry, but I have try this, but it doesn't work.

I compiled and installed the libmcrypt-2.2.4 with --disable-pthreads.

After that I built php-3.0.13 with

./configure 
--with-apxs=/path/apxs 
--with-apache=/some/path/apache_1.3.9 
--with-sybase=/path/sybase 
--with-config-file-path=/path
--with-mcrypt 
--enable-track-vars

Then I start apache: Segmentation Fault
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Dec 07 00:03:19 2022 UTC