|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31273 Analog of #29402 for php 4.3.x
Submitted: 2004-12-23 21:04 UTC Modified: 2004-12-24 11:10 UTC
From: rvs at angara dot ru Assigned:
Status: Closed Package: OCI8 related
PHP Version: 4.3.10 OS: Solaris 9
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: rvs at angara dot ru
New email:
PHP Version: OS:


 [2004-12-23 21:04 UTC] rvs at angara dot ru
The same situation as in #29402 encountered
with php 4.3.10 + Oracle 9.2.0.
The ./configure script fails, and php won't compile.
In 4.3.x this issue is not fixed.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2004-12-23 21:25 UTC] rvs at angara dot ru
Ok tried latest snapshot. The bug still not fixed.
./configure fails due to wrong oracle library model
chosen, please see the config.log entry:

configure:67926: checking for fork
configure:67954: gcc -o conftest -DEAPI  -D_POSIX_PTHREAD_SEMANTICS -L/usr/local/BerkeleyDB.3.3/lib  -R/usr/ucblib -L/usr/ucblib -R/usr/local/lib/gcc-lib/sparc-sun-solaris2.9/3.3.1 -L/usr/local/lib/gcc-lib/sparc-sun-solaris2.9/3.3.1 -R/usr/local/ssl/lib -L/usr/local/ssl/lib -R/usr/local/lib -L/usr/local/lib -R/usr/local/BerkeleyDB.3.3/lib -L/usr/local/BerkeleyDB.3.3/lib -R/export/home/rvs/src/imap-2002e/lib -L/export/home/rvs/src/imap-2002e/lib -R/oracle/orahome/oracle9i/lib -L/oracle/orahome/oracle9i/lib conftest.c -lsybdb -lmcrypt -lltdl -lldap -llber -lcrypt -lpam -liconv -lintl -lgd -lz -ldb-3.3 -ldb-3.3 -lcurl -lz -lssl -lcrypto -lresolv -lm -ldl -lnsl -lsocket  -lgcc -lcurl -lz -lssl -lcrypto -ldl -lsocket -lnsl -lz -lxml2 -lz -liconv -lm -lsocket -lnsl -lnsl -lsocket -lgen -ldl -lclntsh 1>&5
ld: fatal: file /oracle/orahome/oracle9i/lib/ wrong ELF class: ELFCLASS64
ld: fatal: File processing errors. No output written to conftest
collect2: ld returned 1 exit status
configure: failed program was:
#line 67931 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
    which can conflict with char fork(); below.  */
#include <assert.h>
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char fork();

int main() {

/* The GNU C library defines this for functions which it implements
    to always fail with ENOSYS.  Some functions are actually named
    something starting with __ and the normal name is an alias.  */
#if defined (__stub_fork) || defined (__stub___fork)
choke me

; return 0; }
 [2004-12-24 10:28 UTC]
The patch mentioned in #29402 will not be backported to 4.3.x branch, so you need to figure out where your libs are and change "/lib" in ext/oci8/config.m4 to the right dir ("/lib32", probably ?). Run ./buildconf after that and it should work.
Tell me if something will go wrong.

OR you can get latest stable 5.0.x release and it will work for you without any modifications.
 [2004-12-24 10:47 UTC] rvs at angara dot ru
Ok this modification method works,
it's a pity that no permanent patch
will be provided for 4.3.x...
Suggest to mark this bug RESOLVED.
 [2004-12-24 10:50 UTC] rvs at angara dot ru
The bug seems to be resolved.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jun 12 22:01:30 2024 UTC