php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31230 Impossible to instance excel 2000 with COM and php 4.3.10
Submitted: 2004-12-21 14:23 UTC Modified: 2004-12-23 02:43 UTC
From: gdelbar at neu-international dot com Assigned:
Status: Not a bug Package: COM related
PHP Version: 4.3.10 OS: Win2k Server SP4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gdelbar at neu-international dot com
New email:
PHP Version: OS:

 

 [2004-12-21 14:23 UTC] gdelbar at neu-international dot com
Description:
------------
Hello,

i'm using com object to generate excel file on server-side with excel 2000. Everything was OK until i change php from 4.3.9 to 4.3.10 yesterday : I've got some dr watson message's.

Complete config
---------------
Win2k Server SP4
PHP 4.3.10
Apache 1.3.33
Excel 2000

Best Regards,
Guillaume DELBAR.



Reproduce code:
---------------
<?php

//=> No error but no excel instance created on server side
$excel = new COM("Excel.application"); 

//=> Dr Watson
$excel->Quit();

?>

Actual result:
--------------
--------------------- Message --------------------
Une exception d'application s'est produite?:
        App?:  (pid=1172)
        Lorsque?: 21/12/2004 @ 12:13:12.359
        Num?ro d'exception?: c0000005 (violation d'acc?s)

*----> Informations syst?me <----*
        Nom ordinateur?: INFO-60S
        Nom utilisateur?: SYSTEM
        Nombre de processeurs?: 4
        Type de processeur?: x86 Family 15 Model 3 Stepping 4
        Version Windows 2000?: 5.0
        Num?ro actuel?: 2195
        Service Pack?: 4
        Type actuel?: Multiprocessor Free
        Organisation enregistr?e?: NEU International
        Propri?taire enregistr??: sroot_60s

*----> Liste des t?ches <----*
   0 Idle.exe
   8 System.exe
 200 smss.exe
 228 csrss.exe
 248 WINLOGON.exe
 276 services.exe
 288 LSASS.exe
 476 svchost.exe
 504 SPOOLSV.exe
 568 msdtc.exe
 752 dcevt32.exe
 768 dcstor32.exe
 784 DefWatch.exe
 796 svchost.exe
 816 llssrv.exe
 864 xmlclient.exe
 960 mr2kserv.exe
1180 mysqld.exe
1224 Rtvscan.exe
1264 omsad32.exe
1356 regsvc.exe
1368 remotsvc.exe
1380 retroclient.exe
1388 mstask.exe
1444 omaws32.exe
1464 snmp.exe
1488 VxSvc.exe
1508 mgesystray.exe
1556 winmgmt.exe
1564 svchost.exe
1584 dfssvc.exe
2212 svchost.exe
 516 explorer.exe
2484 jusched.exe
2440 VPTray.exe
2480 internat.exe
2156 IEXPLORE.exe
1124 mmc.exe
 980 CMD.exe
 992 weaversl.exe
2336 taskmgr.exe
2240 Apache.exe
1172 Apache.exe
1032 drwtsn32.exe
   0 _Total.exe
-----------------------------------------------------

ps : i can send you the complete message if you want

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-12-21 17:20 UTC] gdelbar at neu-international dot com
I tried this dev version but the problem is still here. A difference : no dr watson message this time.
 [2004-12-23 02:43 UTC] edink@php.net
Dupe of #31159
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 01 04:03:45 2023 UTC