php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31066 Can't dynamic load with module (php.ini)
Submitted: 2004-12-12 22:57 UTC Modified: 2004-12-17 08:52 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: jsgoupil at lookstrike dot com Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 5.0.2 OS: WinXP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
23 + 10 = ?
Subscribe to this entry?

 
 [2004-12-12 22:57 UTC] jsgoupil at lookstrike dot com
Description:
------------
When loading PHP with CGI method, I put the extension_dir to "./ext" and it is working fine.

When I want to load PHP with module method, I got some problem.
First of all, it seems the library can't be loaded. The "./ext" doesn't work. So there are two ways to resolve the problem, copy "ext" dir into C:/Windows or link to "ext" dir with the full path : extension_dir = "C:/php5/ext"

So this is the first problem.

The second one, is that php_mysqli.dll can't be loaded even if I use one of the two mothods I explain above... All other dlls (gd2 and mysql) are loaded but not mysqli...

So I have to stay on php-cgi since you discover the problem...

Notice that it is perhaps not a bug the first one, but it is not normal that it is working with php-cgi and not with module...


I already check the bug http://bugs.php.net/bug.php?id=30636 and it doesn't correspond to this one... I put the C:/php5 to my PATH to be sure.

Furthermore, I tried with / and \ in the extension_dir and it is not working anyway...

I check http://bugs.php.net/bug.php?id=8416 and I've try to copy the ext folder to System32... the second bug is always there.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-12-13 09:04 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

.
 [2004-12-13 18:27 UTC] jsgoupil at lookstrike dot com
I can understand that you receive a lot of bogus bugs and I understand your action by closing this bug and saying nothing about "the question".
Just wondering if I was working in a company that uses PHP, the company could really be angry after your response.

I spent about 2 hours to try to fix the problem by trying with php5.0.2, php5.0.3RC1, apache1.3, apache2 and spent 50 minutes to write this bug and search if it was not existing. I link to possible matching bugs that I have found. When I found a "bug", I really do a check before posting it.

The extension_dir is not pointing to the same dir when Loaded in module or cgi, and mysqli can't be loaded in module method (sI have disabled mysql as the doc say...). I just check again and I a copy a new libmysql.dll in the system32 and now it is working perfectly (just weird that it was working with cgi and not with module).
The "bug" can be corrected by saying in the documentation that module checks the %PATH% in relative and cgi checks first where PHP is installed...

If it really doesn't imply PHP, just saying "implies mysqli" or something like that, and I will understand that you are really busy but at least you would aim me on another direction to take...

(I don't know if you receive a confirmation mail if I let this bug bogus, so I just reopen it. Feel free to close it if this is really not a "bug")

Thank You,
Regards


Jean-Sebastien
 [2004-12-17 08:52 UTC] edink@php.net
You should read the install instructions more carefully. You need to put c:/php5 in your system path or ensure some other way of having those dlls available to your web server.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Mar 03 09:01:28 2024 UTC