php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31006 __get : fictive attribute can be accessed only once !
Submitted: 2004-12-07 10:04 UTC Modified: 2005-01-12 00:56 UTC
From: naholyr at yahoo dot fr Assigned:
Status: Not a bug Package: Class/Object related
PHP Version: 5.0.2 OS: Windows 2K, XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
27 - 25 = ?
Subscribe to this entry?

 
 [2004-12-07 10:04 UTC] naholyr at yahoo dot fr
Description:
------------
See the file in "Reproduce code" section. My english is bad and a sample is always better than explanations.
The method to focus is Field::__get().


In this file you'll find 2 codes:
# BUGGY.PHP
The code which reproduces the bug.

# NOTBUGGY.PHP
The code which works.


We have invented single use attributes ! lol
And the best: __set is not affected...

Reproduce code:
---------------
http://naholyr.free.fr/php/__get.txt

Expected result:
----------------
MyName - MyName

Actual result:
--------------
MyName - Fatal error: Cannot access private property Field::$_value in ### on line ##

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-01-12 00:56 UTC] tony2001@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

Duplicate of #28444.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Jul 14 17:01:28 2024 UTC