php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3098 php doesn't load the php3_mysql.dll file; MySQL support not compiled in php win
Submitted: 2000-01-04 10:38 UTC Modified: 2002-10-01 14:23 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: inertia78 at yahoo dot com Assigned:
Status: Wont fix Package: MySQL related
PHP Version: 3.0.13 OS: Windows 98 SE
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: inertia78 at yahoo dot com
New email:
PHP Version: OS:

 

 [2000-01-04 10:38 UTC] inertia78 at yahoo dot com
This is a problem that seems to have been reported a few times, but gets shot down each time as "NOT A BUG... blah blah," but it still doesn't work:

When running php3 w/Apache and attempting to run mysql function: mysql_connect, the following is returned as an error:

Fatal error: Call to unsupported or undefined function mysql_connect() in f:\html\test.php3 on line 13

Now, the general response to this problem is:
"Mysql support is not compiled in php win32", and
to use: "extension=php3_mysql.dll" in php3.ini or
dl() function.

The reality of the situation is that I have
extension=php3_mysql.dll
in my php3.ini, and it still doesn't solve that problem.
extension=php3_calendar.dll 
works just fine, and Calendar extension shows up in phpinfo(); but Mysql doesn't show up there.

When using dl("php3_mysql.dll");
the following error is returned:
Fatal error: Unable to load dynamic library 'C:/php3/php3_mysql.dll'
One of the library files needed to run this application cannot be found. in f:\html\test.php3 on line 11

And yes, php3_mysql.dll is located in C:\php3.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-01 14:23 UTC] hholzgra@php.net
We are sorry, but can not support PHP 3 related problems anymore.
Momentum is gathering for PHP 5, and we think supporting PHP 3 will
lead to a waste of resources which we want to put into getting PHP 5
ready. Ofcourse PHP 4 will will continue to be supported for the
forseeable future.


 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC