php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3086 PHP.EXE Crashes when reciving from a TCP connection
Submitted: 2000-01-03 08:33 UTC Modified: 2002-10-01 14:23 UTC
From: daniel at restech dot se Assigned:
Status: Wont fix Package: Reproducible Crash
PHP Version: 3.0.11 OS: Win2k/Apache
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: daniel at restech dot se
New email:
PHP Version: OS:

 

 [2000-01-03 08:33 UTC] daniel at restech dot se
I seem to have made something terrebly wrong here, or there is a bug in PHP. I'm constructing an interface for the web that communicates with our (ResTech's) booking system. The comm is established with 'fsockopen' to a listen port in the booking system. Since all data is stored in an SQL on the listening side, some questions take longer than others. It seems that if PHP has to wait too long for the TCP reply, it crashes when it finally arrives (allthough is still not as long as the specified timeout to fsockopen).

This happens about 50% of times, if the reply takes a little time to arrive. When i put in a few echo's in the script for debug purpouses, the problem seems to be eliminated.

Thanks for any reply/suggestion.
/Daniel

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-01 14:23 UTC] hholzgra@php.net
We are sorry, but can not support PHP 3 related problems anymore.
Momentum is gathering for PHP 5, and we think supporting PHP 3 will
lead to a waste of resources which we want to put into getting PHP 5
ready. Ofcourse PHP 4 will will continue to be supported for the
forseeable future.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Nov 26 22:01:23 2020 UTC