php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30706 AND operator
Submitted: 2004-11-06 19:16 UTC Modified: 2004-11-10 17:52 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: kev at aero dot fr Assigned:
Status: Not a bug Package: Math related
PHP Version: 5.0.2 OS: Win2003
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: kev at aero dot fr
New email:
PHP Version: OS:

 

 [2004-11-06 19:16 UTC] kev at aero dot fr
Description:
------------
php5 problem with and operator and big numbers

Reproduce code:
---------------
<?
$c = 4023233417 & 2562383102;
echo $c;
// prints 2147483647
// the right answer is 2290649224 (good with php4)

?>

Expected result:
----------------
the answer isn't good
the script prints 2147483647 and the right answer is 2290649224 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-11-10 17:52 UTC] tony2001@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

Duplicate of #30315.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 17 04:05:45 2022 UTC